Articles of gem

¿Cómo se puede instalar la gem mysql2 cuando se instaló MySQL con homebrew en OS X Lion?

No he podido instalar la gem mysql2 con MySQL instalada a través de homebrew en OS X Lion. He intentado una multitud de banderas con la installation, y todavía no he tenido suerte. Aquí están todos los detalles. Software Mac OS X Lion 10.7 (11A2063) $ uname -a Darwin Greenwood.local 11.0.1 Darwin Kernel Version 11.0.1: […]

less css vía ruby ​​en win 7 – ver mayor que 1.2.21?

¿Hay alguna forma de que alguna de las versiones 2.x funcione a través de Ruby en Windows? gem list –remote –all less todas las versiones enumeradas a través de la gem list –remote –all less El problema es que solo puedo instalar la versión 1.2.21, que no admite el selector & less. Entonces tengo que […]

Problemas con Rails gem mysql2 en OS X 10.7 con Ruby 1.9.2 y Rails 3.1

Versión del sistema operativo : Mac OS X 10.7.1 Lion Versión de Ruby: ruby 1.9.2p290 (2011-07-09 revision 32553) [x86_64-darwin11.1.0] Ruby Ubicación: /usr/local/rvm/bin/ruby Versión de Rails: Rails 3.1.0 Ubicación de los Rails: /usr/local/rvm/gems/ruby-1.9.2-p290/bin/rails Ahora, instalé la gem mysql2 y cuando ejecuto gem list aparece en la list como: mysql2 (0.3.7) Hasta aquí todo bien, ¿no? OK, […]

Cómo formatear date y hora en ruby ​​con Sinatra y Twitter Gem

Soy completamente nuevo en ruby ​​y estoy tratando de formatear el campo created_at extraído de la gem de Twitter. Sé en los Rails que puedes usar time_ago_in_words para barandillas, pero me preguntaba cómo puedes hacerlo en ruby ​​simple. De hecho, me pregunto cómo puede formatear una date que está en este formatting para comenzar con […]

¿Conoces algunas aplicaciones de Ruby para manipular files EPS?

Estoy haciendo una aplicación web usando Rails 3 para hacer algunos dibujos, pero necesito crear files EPS. ¿Conoces alguna gem o api para crear imágenes EPS (PostScript encapsulado)? No estoy cerca de usar otro formatting de image, tal vez SVG (Scalable Vector Graphics) podría ser una alternativa, pero mi requisito era usar EPS. ¡Gracias!

¿Cuál es el estado de la técnica / mejor práctica para implementar la testing de rastrillo de Ruby para gems?

Me gustaría get orientación sobre el estado del arte al escribir testings de ruby ​​e invocarlas desde el rastrillo para get una gem. He estado leyendo en los internets y revisando el código, pero he visto muchas maneras de hacerlo. ¿Cuál es el método líder para implementar testings unitarias usando rake? nota: Estoy usando ruby-1.9.2-p290 […]

ADVERTENCIA: Formato .gemspec no válido en '/Library/Ruby/Gems/1.8/specifications/rack-1.3.5.gemspec'

Estoy intentando ejecutar una aplicación Sinatra, y estoy fallando porque no se encuentra el estante. Estoy teniendo el siguiente error: WARNING: Invalid .gemspec format in '/Library/Ruby/Gems/1.8/specifications/rack-1.3.5.gemspec' /Library/Ruby/Site/1.8/rubygems.rb:636:in `report_activate_error': Could not find RubyGem rack (~> 1.3, >= 1.3.4) (Gem::LoadError) from /Library/Ruby/Site/1.8/rubygems.rb:141:in `activate' from /Library/Ruby/Site/1.8/rubygems.rb:165:in `activate' from /Library/Ruby/Site/1.8/rubygems.rb:164:in `each' from /Library/Ruby/Site/1.8/rubygems.rb:164:in `activate' from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:35:in `require' Estoy ejecutando […]

Cómo empacar el file .gem con cambios

Tengo una duda, Puedo descomprimir la gem 'herubyracer-0.9.9.gem' usando este command gem unpack therubyracer-0.9.9.gem Estoy obteniendo la carpeta therubyracer-0.9.9 Changelog.md Gemfile README.md Rakefile bin / ext / lib / spec / specmem / specthread / therubyracer.gemspec y he copydo el file v8.so en el directory / lib Por favor, avíseme, ¿cómo puedo hacer que el […]

dependencies de Debian para gem gosu

Estoy tratando de gem install gosu pero obtengo muchos posts del comstackdor sobre files de cabecera perdidos, incluido sndfile.h. ¿Hay una list de packages de Debian que se necesitan para comstackr la gem de gosu?

Rails Bundle – una gem dos versiones

Tengo una aplicación antigua de Rails. Y esta aplicación necesita la misma gem con diferentes versiones. Por ejemplo, usa ahora gem 'actionmailer' 2.3.5 y 'actionmailer' 2.3.2 gem 'actionpack', '2.3.5' y 'actionpack', '2.3.2' No me preguntes por qué =) Esta es una aplicación antigua y muy masiva. Carriles actuales versión 2.3.5 Ahora trato de usar bundler […]